> Remove removal and re-addition of freeing functions. I find such a wording confusing for a commit message. > Add position variable on usb_free_urb in the non-patch case. Is it interesting that this fix corresponds to a bug report from 2014-08-09? https://lkml.org/lkml/2014/8/9/33 https://systeme.lip6.fr/pipermail/cocci/2014-August/001038.html > @r depends on context || report || org @ > @@ -36,8 +32,8 @@ expression E; > position p; > @@ > > -* if (E) > -* \(kfree@p\|debugfs_remove@p\|debugfs_remove_recursive@p\|usb_free_urb\)(E); > +* if (E != NULL) > +* \(kfree@p\|debugfs_remove@p\|debugfs_remove_recursive@p\|usb_free_urb@p\)(E); How do you think about to extend the shown function name pattern also with suffixes like the following (besides "destroy")? * put * release * unref * unregister Regards, Markus -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html