From: Firo Yang <firogm@xxxxxxxxx> Date: Fri, 12 Jun 2015 12:57:57 +0800 > Code refactoring: > 1. Move the common code of inet_listen() and inet_dccp_listen() to > sock_common_listen(). > > 2. Modify and rename inet_listen() to tcp_listen(). > > 3. Modify and rename inet_dccp_listen() to dccp_listen(). > > 4. Add new callback pointer listen in struct proto for > tcp_listen() and dccp_listen(). > > This patch makes codes more modularized and removes redudant codes. > > Signed-off-by: Firo Yang <firogm@xxxxxxxxx> > --- > v2: > In according to the advices of Eric Dumazet, sock_common_listen() keep > using TCP_xxx state instead of introducing new aliases. > > Test info: > I test it on my x86 PC. I don't think this is worthwhile, sorry. Instead of having two straight line copies of a piece of logic, we now have three functions and a new callback. I'd rather have a single duplicate copy of a function than all of that. -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html