On 10/02/2012 02:04 PM, Dan Carpenter wrote: > Using ARRAY_SIZE() is more readable. > > Signed-off-by: Dan Carpenter <dan.carpenter@xxxxxxxxxx> > Reviewed-by: Srivatsa S. Bhat <srivatsa.bhat@xxxxxxxxxxxxxxxxxx> Regards, Srivatsa S. Bhat > diff --git a/arch/x86/kernel/cpu/intel_cacheinfo.c b/arch/x86/kernel/cpu/intel_cacheinfo.c > index 9a7c90d..93c5451 100644 > --- a/arch/x86/kernel/cpu/intel_cacheinfo.c > +++ b/arch/x86/kernel/cpu/intel_cacheinfo.c > @@ -991,7 +991,7 @@ static struct attribute ** __cpuinit amd_l3_attrs(void) > if (attrs) > return attrs; > > - n = sizeof (default_attrs) / sizeof (struct attribute *); > + n = ARRAY_SIZE(default_attrs); > > if (amd_nb_has_feature(AMD_NB_L3_INDEX_DISABLE)) > n += 2; > -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html