Hi Julia, Kukjin Kim, > > Hmm...I think, 'res' is better for platform_get_resource(). > > Do we _really_ need to change the name?... > > wdt_mem is a global variable. Is res a good name for a global variable? > One could say wdt_mem = res, if that seems better. If you look at the code then you have: static struct resource *wdt_mem; static struct resource *wdt_irq; and in the probe function you have: res = platform_get_resource(pdev, IORESOURCE_MEM, 0); ... wdt_mem = request_mem_region(res->start, size, pdev->name); ... wdt_irq = platform_get_resource(pdev, IORESOURCE_IRQ, 0); So doing Julia's: wdt_mem = platform_get_resource(pdev, IORESOURCE_MEM, 0); ... if (!request_mem_region(wdt_mem->start, size, pdev->name)) { ... wdt_irq = platform_get_resource(pdev, IORESOURCE_IRQ, 0) seems the best solution to me (since you then have both resources being polulated via platform_get_resource(pdev,... ). Kind regards, Wim. -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html