Re: [PATCH 11/25] block: Convert pci_table entries to PCI_VDEVICE (if PCI_ANY_ID is used)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 07/15/2010 03:03 PM, Alexey Dobriyan wrote:
On Thu, Jul 15, 2010 at 08:51:17PM +0200, Peter Huewe wrote:
This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and
.subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the
PCI_VDEVICE macro, and thus improves readability.

Well, it doesn't improve readability, and ## usage prevents grepping and
long term plan to switch to numbers instead of PCI_VENDOR_ID_*,
but whatever.

-	{ PCI_VENDOR_ID_PROMISE, 0x8000, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
-	{ PCI_VENDOR_ID_PROMISE, 0x8002, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
+	{ PCI_VDEVICE(PROMISE, 0x8000), },
+	{ PCI_VDEVICE(PROMISE, 0x8002), },

Switching to use hex numbers for _device ids_ is encouraged, because history has proven its pointless to create named constants for single-use ids. However, using named constants for PCI vendor ids makes a lot of sense.

	Jeff




--
To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Kernel Development]     [Kernel Announce]     [Kernel Newbies]     [Linux Networking Development]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Device Mapper]

  Powered by Linux