From: Peter Huewe <peterhuewe@xxxxxx> This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and .subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the PCI_VDEVICE macro, and thus improves readability. Signed-off-by: Peter Huewe <peterhuewe@xxxxxx> --- drivers/char/synclinkmp.c | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/char/synclinkmp.c b/drivers/char/synclinkmp.c index e56caf7..9f9cd8f 100644 --- a/drivers/char/synclinkmp.c +++ b/drivers/char/synclinkmp.c @@ -482,7 +482,7 @@ static int synclinkmp_init_one(struct pci_dev *dev,const struct pci_device_id *e static void synclinkmp_remove_one(struct pci_dev *dev); static struct pci_device_id synclinkmp_pci_tbl[] = { - { PCI_VENDOR_ID_MICROGATE, PCI_DEVICE_ID_MICROGATE_SCA, PCI_ANY_ID, PCI_ANY_ID, }, + { PCI_VDEVICE(MICROGATE, PCI_DEVICE_ID_MICROGATE_SCA), }, { 0, }, /* terminate list */ }; MODULE_DEVICE_TABLE(pci, synclinkmp_pci_tbl); -- 1.7.1 -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html