From: Peter Huewe <peterhuewe@xxxxxx> This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and .subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the PCI_VDEVICE macro, and thus improves readability. Signed-off-by: Peter Huewe <peterhuewe@xxxxxx> --- drivers/char/synclink.c | 4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/char/synclink.c b/drivers/char/synclink.c index a2a5800..a5941a4 100644 --- a/drivers/char/synclink.c +++ b/drivers/char/synclink.c @@ -889,8 +889,8 @@ static int synclink_init_one (struct pci_dev *dev, static void synclink_remove_one (struct pci_dev *dev); static struct pci_device_id synclink_pci_tbl[] = { - { PCI_VENDOR_ID_MICROGATE, PCI_DEVICE_ID_MICROGATE_USC, PCI_ANY_ID, PCI_ANY_ID, }, - { PCI_VENDOR_ID_MICROGATE, 0x0210, PCI_ANY_ID, PCI_ANY_ID, }, + { PCI_VDEVICE(MICROGATE, PCI_DEVICE_ID_MICROGATE_USC), }, + { PCI_VDEVICE(MICROGATE, 0x0210), }, { 0, }, /* terminate list */ }; MODULE_DEVICE_TABLE(pci, synclink_pci_tbl); -- 1.7.1 -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html