On Sun, Aug 02, 2009 at 10:49:54AM +0200, Julia Lawall wrote: > From: Julia Lawall <julia@xxxxxxx> > > The kernel.h macro DIV_ROUND_CLOSEST performs the computation (x + d/2)/d > but is perhaps more readable. > > The semantic patch that makes this change is as follows: > (http://www.emn.fr/x-info/coccinelle/) > > // <smpl> > @haskernel@ > @@ > > #include <linux/kernel.h> > > @depends on haskernel@ > expression x,__divisor; > @@ > > - (((x) + ((__divisor) / 2)) / (__divisor)) > + DIV_ROUND_CLOSEST(x,__divisor) > // </smpl> > > Signed-off-by: Julia Lawall <julia@xxxxxxx> Acked-by: Borislav Petkov <petkovbb@xxxxxxxxx> -- Regards/Gruss, Boris. -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html