At Thu, 1 Jan 2009 18:14:35 +0100 (CET), Julia Lawall wrote: > > From: Julia Lawall <julia@xxxxxxx> > > Use the USB functions usb_get_intfdata and usb_set_intfdata instead of > dev_get_drvdata and dev_set_drvdata, respectively. > > The semantic patch that makes this change for the usb_get_intfdata case is > as follows: (http://www.emn.fr/x-info/coccinelle/) > > // <smpl> > @header@ > @@ > > #include <linux/usb.h> > > @same depends on header@ > position p; > @@ > > usb_get_intfdata@p(...) { ... } > > @depends on header@ > position _p!=same.p; > identifier _f; > struct usb_interface*intf; > @@ > > _f@_p(...) { <+... > - dev_get_drvdata(&intf->dev) > + usb_get_intfdata(intf) > ...+> } > // </smpl> > > Signed-off-by: Julia Lawall <julia@xxxxxxx> Applied now. Thanks. Takashi -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html