Re: [PATCH 3/3] remove explicit memset to memory allocated with k[zc]alloc

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Dec 18, 2007 at 11:53:58PM +0100, Andi Drebes wrote:
> Hi!
> 
> > 1) Remove an explicit memset(.., 0, ...) to a varialable allocated with
> > kzalloc.
> > 
> > 2) Allocate 'src' with kmalloc instead of kzalloc as all elements of the
> > 'src' buffer are initialized in a 'for(...)' loop
> The changes look good to me, but there's another thing that could be done in that file:
> There's no need for the expression "sizeof(u8)" since it always returns 1. Could you
> fix that too and submit a new patch?
> 
> There are quite a lot of statements like that in the kernel...
> 
> $ grep -r "sizeof(u8)" . | wc -l
> 53

What is the problem you are trying to solve?

It might in some places be an improvement to replace a sizeof(u8) with a 
sizeof() on the actual variable, but blindly replacing sizeof(u8) with 1 
sounds like an attempt to make the code harder to read without bringing 
any advantage...

> Regards,
> 	Andi

cu
Adrian

-- 

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

-
To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Kernel Development]     [Kernel Announce]     [Kernel Newbies]     [Linux Networking Development]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Device Mapper]

  Powered by Linux