Re: [PATCH] kbuild: Fix names of .tmp_vmlinux kallsyms files

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, Nov 23, 2024 at 10:22 PM Sedat Dilek <sedat.dilek@xxxxxxxxx> wrote:
>
> For details, see thread "kbuild-next: .tmp vmlinux syms files"
>
> INFO: This patch is against Linux v6.12.
>
> Link: https://lore.kernel.org/all/CA+icZUXvu0Kw8RH1ZGBKgYGG-8u9x8BbsEkjtm4vSVKkXPTg+Q@xxxxxxxxxxxxxx/

This is not the right way to input a commit description.




>
> Signed-off-by: Sedat Dilek <sedat.dilek@xxxxxxxxx>
> ---
>  scripts/link-vmlinux.sh | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
> index a9b3f34a78d2..c9088436baff 100755
> --- a/scripts/link-vmlinux.sh
> +++ b/scripts/link-vmlinux.sh
> @@ -203,8 +203,8 @@ kallsymso=
>  strip_debug=
>
>  if is_enabled CONFIG_KALLSYMS; then
> -       true > .tmp_vmlinux.kallsyms0.syms
> -       kallsyms .tmp_vmlinux.kallsyms0.syms .tmp_vmlinux0.kallsyms
> +       true > .tmp_vmlinux0.kallsyms.syms
> +       kallsyms .tmp_vmlinux0.kallsyms.syms .tmp_vmlinux0.kallsyms

If you aim for naming consistency, this should be

.tmp_vmlinux0.syms



>  fi
>
>  if is_enabled CONFIG_KALLSYMS || is_enabled CONFIG_DEBUG_INFO_BTF; then
> @@ -231,14 +231,14 @@ if is_enabled CONFIG_KALLSYMS; then
>         # Generate section listing all symbols and add it into vmlinux
>         # It's a four step process:
>         # 0)  Generate a dummy __kallsyms with empty symbol list.
> -       # 1)  Link .tmp_vmlinux.kallsyms1 so it has all symbols and sections,
> +       # 1)  Link .tmp_vmlinux1.kallsyms so it has all symbols and sections,
>         #     with a dummy __kallsyms.
> -       #     Running kallsyms on that gives us .tmp_kallsyms1.o with
> +       #     Running kallsyms on that gives us .tmp_vmlinux1.kallsyms.o with
>         #     the right size
> -       # 2)  Link .tmp_vmlinux.kallsyms2 so it now has a __kallsyms section of
> +       # 2)  Link .tmp_vmlinux2.kallsyms so it now has a __kallsyms section of
>         #     the right size, but due to the added section, some
>         #     addresses have shifted.
> -       #     From here, we generate a correct .tmp_vmlinux.kallsyms2.o
> +       #     From here, we generate a correct .tmp_vmlinux2.kallsyms.o
>         # 3)  That link may have expanded the kernel image enough that
>         #     more linker branch stubs / trampolines had to be added, which
>         #     introduces new names, which further expands kallsyms. Do another
> --
> 2.45.2
>


-- 
Best Regards
Masahiro Yamada





[Index of Archives]     [Linux&nblp;USB Development]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite Secrets]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux