Re: [PATCH] docs: media: rename gen_rst -> cmd_parse_headers

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Jan 12, 2024 at 9:09 PM Vegard Nossum <vegard.nossum@xxxxxxxxxx> wrote:
>
> All other commands in the kernel use the format "cmd_" followed by some
> variation of the program name. This is also the format documented in
> Documentation/kbuild/makefiles.rst.


This rule is only applicable to Makefiles that follow Kbuild.


The doc subsystem maintainers ignored Kbuild and
started whatever they wanted.
Presumably it is an unfortunate thing.





>
> Therefore, rename "gen_rst" to "cmd_parse_headers".


Just renaming is meaningless.


The reason for "cmd_" prefixing is to
use the macros in scripts/Kbuild.include


In Kbuild, the rule looks like
$(call cmd,parse_headers)








>
> Cc: Mauro Carvalho Chehab <mchehab@xxxxxxxxxx>
> Cc: Masahiro Yamada <masahiroy@xxxxxxxxxx>
> Signed-off-by: Vegard Nossum <vegard.nossum@xxxxxxxxxx>
> ---
>  Documentation/userspace-api/media/Makefile | 22 +++++++++++-----------
>  1 file changed, 11 insertions(+), 11 deletions(-)
>
> diff --git a/Documentation/userspace-api/media/Makefile b/Documentation/userspace-api/media/Makefile
> index 3d8aaf5c253b..bfb90fa2b3fc 100644
> --- a/Documentation/userspace-api/media/Makefile
> +++ b/Documentation/userspace-api/media/Makefile
> @@ -12,38 +12,38 @@ FILES = ca.h.rst dmx.h.rst frontend.h.rst net.h.rst \
>
>  TARGETS := $(addprefix $(BUILDDIR)/, $(FILES))
>
> -gen_rst = \
> +cmd_parse_headers = \
>         echo ${PARSER} $< $@ $(SRC_DIR)/$(notdir $@).exceptions; \
>         ${PARSER} $< $@ $(SRC_DIR)/$(notdir $@).exceptions
>
> -quiet_gen_rst = echo '  PARSE   $(patsubst $(srctree)/%,%,$<)'; \
> +quiet_cmd_parse_headers = echo '  PARSE   $(patsubst $(srctree)/%,%,$<)'; \
>         ${PARSER} $< $@ $(SRC_DIR)/$(notdir $@).exceptions
>
> -silent_gen_rst = ${gen_rst}
> +silent_cmd_parse_headers = ${cmd_parse_headers}
>
>  $(BUILDDIR)/ca.h.rst: ${UAPI}/dvb/ca.h ${PARSER} $(SRC_DIR)/ca.h.rst.exceptions
> -       @$($(quiet)gen_rst)
> +       @$($(quiet)cmd_parse_headers)
>
>  $(BUILDDIR)/dmx.h.rst: ${UAPI}/dvb/dmx.h ${PARSER} $(SRC_DIR)/dmx.h.rst.exceptions
> -       @$($(quiet)gen_rst)
> +       @$($(quiet)cmd_parse_headers)
>
>  $(BUILDDIR)/frontend.h.rst: ${UAPI}/dvb/frontend.h ${PARSER} $(SRC_DIR)/frontend.h.rst.exceptions
> -       @$($(quiet)gen_rst)
> +       @$($(quiet)cmd_parse_headers)
>
>  $(BUILDDIR)/net.h.rst: ${UAPI}/dvb/net.h ${PARSER} $(SRC_DIR)/net.h.rst.exceptions
> -       @$($(quiet)gen_rst)
> +       @$($(quiet)cmd_parse_headers)
>
>  $(BUILDDIR)/videodev2.h.rst: ${UAPI}/videodev2.h ${PARSER} $(SRC_DIR)/videodev2.h.rst.exceptions
> -       @$($(quiet)gen_rst)
> +       @$($(quiet)cmd_parse_headers)
>
>  $(BUILDDIR)/media.h.rst: ${UAPI}/media.h ${PARSER} $(SRC_DIR)/media.h.rst.exceptions
> -       @$($(quiet)gen_rst)
> +       @$($(quiet)cmd_parse_headers)
>
>  $(BUILDDIR)/cec.h.rst: ${UAPI}/cec.h ${PARSER} $(SRC_DIR)/cec.h.rst.exceptions
> -       @$($(quiet)gen_rst)
> +       @$($(quiet)cmd_parse_headers)
>
>  $(BUILDDIR)/lirc.h.rst: ${UAPI}/lirc.h ${PARSER} $(SRC_DIR)/lirc.h.rst.exceptions
> -       @$($(quiet)gen_rst)
> +       @$($(quiet)cmd_parse_headers)
>
>  # Media build rules
>
> --
> 2.34.1
>


--
Best Regards
Masahiro Yamada





[Index of Archives]     [Linux&nblp;USB Development]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite Secrets]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux