On Tue, Aug 31, 2021 at 12:40 AM Masahiro Yamada <masahiroy@xxxxxxxxxx> wrote: > > Rename __objtool_obj to objtool, and move it out of the > 'ifndef CONFIG_LTO_CLANG' conditional, so it can be used for > cmd_cc_lto_link_modules as well. > > Signed-off-by: Masahiro Yamada <masahiroy@xxxxxxxxxx> Reviewed-by: Nick Desaulniers <ndesaulniers@xxxxxxxxxx> > --- > > scripts/Makefile.build | 11 +++++------ > 1 file changed, 5 insertions(+), 6 deletions(-) > > diff --git a/scripts/Makefile.build b/scripts/Makefile.build > index 17508c0e4358..e78096cd396b 100644 > --- a/scripts/Makefile.build > +++ b/scripts/Makefile.build > @@ -225,6 +225,8 @@ endif # CONFIG_FTRACE_MCOUNT_USE_RECORDMCOUNT > > ifdef CONFIG_STACK_VALIDATION > > +objtool := $(objtree)/tools/objtool/objtool > + > objtool_args = \ > $(if $(CONFIG_UNWINDER_ORC),orc generate,check) \ > $(if $(part-of-module), --module) \ > @@ -236,17 +238,15 @@ objtool_args = \ > > ifndef CONFIG_LTO_CLANG > > -__objtool_obj := $(objtree)/tools/objtool/objtool > - > # 'OBJECT_FILES_NON_STANDARD := y': skip objtool checking for a directory > # 'OBJECT_FILES_NON_STANDARD_foo.o := 'y': skip objtool checking for a file > # 'OBJECT_FILES_NON_STANDARD_foo.o := 'n': override directory skip for a file > cmd_objtool = $(if $(patsubst y%,, \ > $(OBJECT_FILES_NON_STANDARD_$(basetarget).o)$(OBJECT_FILES_NON_STANDARD)n), \ > - $(__objtool_obj) $(objtool_args) $@) > + $(objtool) $(objtool_args) $@) > objtool_obj = $(if $(patsubst y%,, \ > $(OBJECT_FILES_NON_STANDARD_$(basetarget).o)$(OBJECT_FILES_NON_STANDARD)n), \ > - $(__objtool_obj)) > + $(objtool)) > > endif # CONFIG_LTO_CLANG > endif # CONFIG_STACK_VALIDATION > @@ -300,8 +300,7 @@ cmd_cc_lto_link_modules = \ > ifdef CONFIG_STACK_VALIDATION > # objtool was skipped for LLVM bitcode, run it now that we have compiled > # modules into native code > -cmd_cc_lto_link_modules += ; \ > - $(objtree)/tools/objtool/objtool $(objtool_args) --module $@ > +cmd_cc_lto_link_modules += ; $(objtool) $(objtool_args) --module $@ > endif > > $(obj)/%.lto.o: $(obj)/%.o FORCE > -- > 2.30.2 > -- Thanks, ~Nick Desaulniers