On Tue, Nov 17, 2020 at 01:51:43PM -0800, Kees Cook wrote: > On Fri, Nov 13, 2020 at 12:55:53PM -0700, Nathan Chancellor wrote: > > config LD_ORPHAN_WARN > > - def_bool ARCH_WANT_LD_ORPHAN_WARN && $(ld-option,--orphan-handling=warn) > > + def_bool ARCH_WANT_LD_ORPHAN_WARN && $(ld-option,--orphan-handling=warn) && (!LD_IS_LLD || LLD_VERSION >= 110000) > > Readability nit-pick... I prefer separate "depends" lines to make things > a little easier to parse, change, etc: > > config LD_ORPHAN_WARN > def_bool y > depends on ARCH_WANT_LD_ORPHAN_WARN > depends on !LD_IS_LLD || LLD_VERSION >= 110000 > depends on $(ld-option,--orphan-handling=warn) > > Otherwise, yeah, looks good to me. With this and the other suggestions, > please consider it: > > Reviewed-by: Kees Cook <keescook@xxxxxxxxxxxx> Thank you, I have updated it locally for v2! Cheers, Nathan