In the next commit, I will re-use this for thin-archives of objects liked into modules. Rename cmd_ar_builtin to a more generic cmd_ar_no_sym. (cmd_ar is already defined in scripts/Makefile.lib) I removed unneeded ifdef builtin-target. No functional change intended. Signed-off-by: Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx> --- scripts/Makefile.build | 8 +++----- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/scripts/Makefile.build b/scripts/Makefile.build index b0ff60ac0c42..68622cbdfda5 100644 --- a/scripts/Makefile.build +++ b/scripts/Makefile.build @@ -404,16 +404,14 @@ $(sort $(subdir-obj-y)): $(subdir-ym) ; # # Rule to compile a set of .o files into one .a file (without symbol table) # -ifdef builtin-target -quiet_cmd_ar_builtin = AR $@ - cmd_ar_builtin = rm -f $@; $(AR) rcSTP$(KBUILD_ARFLAGS) $@ $(real-prereqs) +quiet_cmd_ar_no_sym = AR $@ + cmd_ar_no_sym = rm -f $@; $(AR) rcSTP$(KBUILD_ARFLAGS) $@ $(real-prereqs) $(builtin-target): $(real-obj-y) FORCE - $(call if_changed,ar_builtin) + $(call if_changed,ar_no_sym) targets += $(builtin-target) -endif # builtin-target # # Rule to create modules.order file -- 2.17.1