On Fri, 6 Nov 2009 12:54:10 am Alan Jenkins wrote: > Sam Ravnborg wrote: > > On Wed, Nov 04, 2009 at 10:00:50AM +0000, Alan Jenkins wrote: > > > >> Rusty Russell wrote: > >> > >>> On Tue, 3 Nov 2009 08:36:17 pm Alan Jenkins wrote: > >>> > >>> > >>>> +/* > >>>> + * We use CPP macros since they are more familiar than assembly macros. > >>>> + * Note that CPP macros eat newlines, so each statement must be terminated > >>>> + * by a semicolon. > >>>> + */ > >>>> + > >>>> +#ifdef CONFIG_HAVE_SYMBOL_PREFIX > >>>> +#define __SYM(sym) _##sym > >>>> +#else > >>>> +#define __SYM(sym) sym > >>>> +#endif > >>>> > >>>> > >>> Ideally, you would used MODULE_SYMBOL_PREFIX here, but of course it's a > >>> string. I don't think Kconfig can do arbitrary identifiers, so we can't > >>> make CONFIG_SYMBOL_PREFIX empty or _. > >>> > >>> Perhaps clarify it to a bool CONFIG_HAVE_MODULE_UNDERSCORE_PREFIX then, > >>> since that's what you're assuming here? > >>> > >>> Thanks, > >>> Rusty. > >>> > >> I made the same assumption in patch 4. The arch defines > >> CONFIG_HAVE_SYMBOL_PREFIX, which then causes init/Kconfig to define > >> CONFIG_SYMBOL_PREFIX="_". > >> > >> Mike suggested that I hack kbuild instead, to do something like > >> > >> unquote = ... > >> AFLAGS_.tmp_export-asm.o += -DSYMBOL_PREFIX=$(unquote CONFIG_SYMBOL_PREFIX) > >> > >> I'm experimenting with the idea, but I haven't managed to get it working > >> > > > > Something like this: > > unquote = $(patsubst "%",%,$($1)) > > > > AFLAGS_.tmp_export-asm.o += -DSYMBOL_PREFIX=$(call unquote,CONFIG_SYMBOL_PREFIX) > > > > But the readability is low so we could be better off doing it direct: > > > > AFLAGS_.tmp_export-asm.o += -DSYMBOL_PREFIX=$(patsubst "%",",$(CONFIG_SYMBOL_PREFIX)) > > > > Sam > > > > Thanks to both of you, I have something that works now. I've taken this, but really, it's overkill. Changing the config to a fixed "underscore or nothing" was simpler and demonstrably sufficient for all cases in the last 5 years. Thanks, Rusty. -- To unsubscribe from this list: send the line "unsubscribe linux-kbuild" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html