Re: [PATCH v12 02/10] crypto: Add support for ECDSA signature verification

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Jul 22, 2024 at 08:19:41AM -0400, Stefan Berger wrote:
> On 7/17/24 12:17, Lukas Wunner wrote:
> > On Tue, Mar 16, 2021 at 05:07:32PM -0400, Stefan Berger wrote:
> > > +/*
> > > + * Get the r and s components of a signature from the X509 certificate.
> > > + */
> > > +static int ecdsa_get_signature_rs(u64 *dest, size_t hdrlen, unsigned char tag,
> > > +				  const void *value, size_t vlen, unsigned int ndigits)
> > > +{
> > > +	size_t keylen = ndigits * sizeof(u64);
> > > +	ssize_t diff = vlen - keylen;
> > > +	const char *d = value;
> > > +	u8 rs[ECC_MAX_BYTES];
> > > +
> > > +	if (!value || !vlen)
> > > +		return -EINVAL;
> > > +
> > > +	/* diff = 0: 'value' has exacly the right size
> > > +	 * diff > 0: 'value' has too many bytes; one leading zero is allowed that
> > > +	 *           makes the value a positive integer; error on more
> > > +	 * diff < 0: 'value' is missing leading zeros, which we add
> > > +	 */
> > > +	if (diff > 0) {
> > > +		/* skip over leading zeros that make 'value' a positive int */
> > > +		if (*d == 0) {
> > > +			vlen -= 1;
> > > +			diff--;
> > > +			d++;
> > > +		}
> > > +		if (diff)
> > > +			return -EINVAL;
> > > +	}
> > > +	if (-diff >= keylen)
> > > +		return -EINVAL;
> > 
> > There's an oddity in the above-quoted function.  The check ...
> > 
> > +	if (-diff >= keylen)
> > +		return -EINVAL;
> > 
> > ... seems superfluous.
> 
> You're right, this check is not necessary.

After staring at the code a little longer I've realized that
the purpose of this if-clause is likely to check for a signed
integer overflow.  So it *does* seem to have a purpose,
but it's quite subtle and not very obvious.

I've provisionally added the (untested) commit below to my
development branch to make it more obvious what's going on.
Using check_sub_overflow() might be an alternative.

I want to ask mips maintainers first whether signed integer
overflows can really cause an exception on their arch
as commit 36ccf1c0e391 suggests, despite -fno-strict-overflow...

-- >8 --

Subject: [PATCH] crypto: ecdsa - Avoid signed integer overflow on signature
 decoding

When extracting a signature component R or S from an ASN.1-encoded
integer, ecdsa_get_signature_rs() subtracts the expected length
"bufsize" from the ASN.1 length "vlen" (both of unsigned type size_t)
and stores the result in "diff" (of signed type ssize_t).

This results in a signed integer overflow if vlen > SSIZE_MAX + bufsize.

The kernel is compiled with -fno-strict-overflow, which implies -fwrapv,
meaning signed integer overflow is not undefined behavior.  And the
function does check for overflow:

       if (-diff >= bufsize)
               return -EINVAL;

However that's not very readable and may trigger a false-positive with
CONFIG_UBSAN_SIGNED_WRAP=y.  It also seems that certain Mips CPUs may
raise an exception regardless of -fno-strict-overflow (see do_ov() in
arch/mips/kernel/traps.c).

Avoid by comparing the two unsigned variables directly and erroring out
if "vlen" is too large.

Signed-off-by: Lukas Wunner <lukas@xxxxxxxxx>
---
 crypto/ecdsa.c | 17 ++++-------------
 1 file changed, 4 insertions(+), 13 deletions(-)

diff --git a/crypto/ecdsa.c b/crypto/ecdsa.c
index 08c2c76..0cead9b 100644
--- a/crypto/ecdsa.c
+++ b/crypto/ecdsa.c
@@ -36,29 +36,20 @@ static int ecdsa_get_signature_rs(u64 *dest, size_t hdrlen, unsigned char tag,
 				  const void *value, size_t vlen, unsigned int ndigits)
 {
 	size_t bufsize = ndigits * sizeof(u64);
-	ssize_t diff = vlen - bufsize;
 	const char *d = value;
 
-	if (!value || !vlen)
+	if (!value || !vlen || vlen > bufsize + 1)
 		return -EINVAL;
 
-	/* diff = 0: 'value' has exacly the right size
-	 * diff > 0: 'value' has too many bytes; one leading zero is allowed that
-	 *           makes the value a positive integer; error on more
-	 * diff < 0: 'value' is missing leading zeros
-	 */
-	if (diff > 0) {
+	if (vlen > bufsize) {
 		/* skip over leading zeros that make 'value' a positive int */
 		if (*d == 0) {
 			vlen -= 1;
-			diff--;
 			d++;
-		}
-		if (diff)
+		} else {
 			return -EINVAL;
+		}
 	}
-	if (-diff >= bufsize)
-		return -EINVAL;
 
 	ecc_digits_from_bytes(d, vlen, dest, ndigits);
 
-- 
2.43.0




[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [Linux Kernel]     [Linux Kernel Hardening]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux SCSI]

  Powered by Linux