On Thu, Sep 29, 2022 at 10:17:27AM +0200, Christoph Hellwig wrote: > > +EXPORT_SYMBOL(vfs_set_acl); > > I think all this stackable file system infrastucture should be > EXPORT_SYMBOL_GPL, like a lot of the other internal stuff. Ok, sounds good. > > > +int xattr_permission(struct user_namespace *mnt_userns, struct inode *inode, > > + const char *name, int mask) > > Hmm. The only think ACLs actually need from xattr_permission are > the immutable / append check and the HAS_UNMAPPED_ID one. I'd rather > open code that, or if you cane come up with a sane name do a smaller > helper rather than doing all the strcmp on the prefixes for now > good reason. I'll see if a little helper makes more sense than open-coding. > > > +static inline int vfs_set_acl(struct user_namespace *mnt_userns, > > + struct dentry *dentry, const char *name, > > + struct posix_acl *acl) > > +{ > > + return 0; > > Should this really return 0 if ACLs are not supported? Yeah, we should probably -EOPNOTSUPP for all of: vfs_{get,set,remove}_acl() in this case. Good point, thanks!