On Mon, Aug 09, 2021 at 09:52:20AM +0200, Ahmad Fatoum wrote: > Hello Sumit, > > On 22.07.21 08:31, Sumit Garg wrote: > > On Wed, 21 Jul 2021 at 22:19, Ahmad Fatoum <a.fatoum@xxxxxxxxxxxxxx> wrote: > >> > >> The two existing trusted key sources don't make use of the kernel RNG, > >> but instead let the hardware that does the sealing/unsealing also > >> generate the random key material. While a previous change offers users > >> the choice to use the kernel RNG instead for both, new trust sources > >> may want to unconditionally use the kernel RNG for generating key > >> material, like it's done elsewhere in the kernel. > >> > >> This is especially prudent for hardware that has proven-in-production > >> HWRNG drivers implemented, as otherwise code would have to be duplicated > >> only to arrive at a possibly worse result. > >> > >> Make this possible by turning struct trusted_key_ops::get_random > >> into an optional member. If a driver leaves it NULL, kernel RNG > >> will be used instead. > >> > >> Signed-off-by: Ahmad Fatoum <a.fatoum@xxxxxxxxxxxxxx> > >> --- > >> To: James Bottomley <jejb@xxxxxxxxxxxxx> > >> To: Jarkko Sakkinen <jarkko@xxxxxxxxxx> > >> To: Mimi Zohar <zohar@xxxxxxxxxxxxx> > >> To: David Howells <dhowells@xxxxxxxxxx> > >> Cc: James Morris <jmorris@xxxxxxxxx> > >> Cc: "Serge E. Hallyn" <serge@xxxxxxxxxx> > >> Cc: "Horia Geantă" <horia.geanta@xxxxxxx> > >> Cc: Aymen Sghaier <aymen.sghaier@xxxxxxx> > >> Cc: Herbert Xu <herbert@xxxxxxxxxxxxxxxxxxx> > >> Cc: "David S. Miller" <davem@xxxxxxxxxxxxx> > >> Cc: Udit Agarwal <udit.agarwal@xxxxxxx> > >> Cc: Eric Biggers <ebiggers@xxxxxxxxxx> > >> Cc: Jan Luebbe <j.luebbe@xxxxxxxxxxxxxx> > >> Cc: David Gstir <david@xxxxxxxxxxxxx> > >> Cc: Richard Weinberger <richard@xxxxxx> > >> Cc: Franck LENORMAND <franck.lenormand@xxxxxxx> > >> Cc: Sumit Garg <sumit.garg@xxxxxxxxxx> > >> Cc: keyrings@xxxxxxxxxxxxxxx > >> Cc: linux-crypto@xxxxxxxxxxxxxxx > >> Cc: linux-integrity@xxxxxxxxxxxxxxx > >> Cc: linux-kernel@xxxxxxxxxxxxxxx > >> Cc: linux-security-module@xxxxxxxxxxxxxxx > >> --- > >> include/keys/trusted-type.h | 2 +- > >> security/keys/trusted-keys/trusted_core.c | 2 +- > >> 2 files changed, 2 insertions(+), 2 deletions(-) > >> > >> diff --git a/include/keys/trusted-type.h b/include/keys/trusted-type.h > >> index d89fa2579ac0..4eb64548a74f 100644 > >> --- a/include/keys/trusted-type.h > >> +++ b/include/keys/trusted-type.h > >> @@ -64,7 +64,7 @@ struct trusted_key_ops { > >> /* Unseal a key. */ > >> int (*unseal)(struct trusted_key_payload *p, char *datablob); > >> > >> - /* Get a randomized key. */ > >> + /* Optional: Get a randomized key. */ > >> int (*get_random)(unsigned char *key, size_t key_len); > >> > >> /* Exit key interface. */ > >> diff --git a/security/keys/trusted-keys/trusted_core.c b/security/keys/trusted-keys/trusted_core.c > >> index 569af9af8df0..d2b7626cde8b 100644 > >> --- a/security/keys/trusted-keys/trusted_core.c > >> +++ b/security/keys/trusted-keys/trusted_core.c > >> @@ -334,7 +334,7 @@ static int __init init_trusted(void) > >> continue; > >> > >> get_random = trusted_key_sources[i].ops->get_random; > >> - if (trusted_kernel_rng) > >> + if (trusted_kernel_rng || !get_random) > >> get_random = kernel_get_random; > >> > > > > For ease of understanding, I would prefer to write it as: > > > > get_random = trusted_key_sources[i].ops->get_random ?: > > kernel_get_random; > > if (trusted_kernel_rng) > > get_random = kernel_get_random; > > > > With that: > > > > Acked-by: Sumit Garg <sumit.garg@xxxxxxxxxx> > > I don't think it improves readability to split up the conditional. > At least I need to take a second pass over the code to understand > the second conditional. Ternary operators are pain to read, unless a super trivial case. I'd stick to what you did. /Jarkko