Hi Mimi, Petr,
On 7/19/21 8:51 PM, Mimi Zohar wrote:
Hi -
On Sun, 2021-07-18 at 15:20 +0200, Petr Vorel wrote:
On 7/17/21 12:39 AM, Mimi Zohar wrote:
On Fri, 2021-07-16 at 17:22 +0800, Tianjia Zhang wrote:
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 088c041..17407ff 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -17,6 +17,7 @@ jobs:
ARCH: i386
TSS: tpm2-tss
VARIANT: i386
+ OPENSSL3: true
# cross compilation builds
- container: "debian:stable"
@@ -51,6 +52,7 @@ jobs:
env:
CC: clang
TSS: ibmtss
+ OPENSSL3: true
I haven't had a chance to look at the entire patch, but defining
OPENSSL3 kind of stood out. Just as "CC" and "TSS" are generic, I'd
prefer something more generic here. In the past there was a request
to support Libressl, which never materialized.
I agree that it is appropriate to use a generic variable name. I am thinking
of 'CRYPTOGRAPHY' or 'CRYPPTO_LIBRARY'. Are there any better suggestions?
How about COMPILE_OPENSSL? Because that's the current purpose.
Hm, wondering if it makes sense to generalize this further, including
Vitaly's suggestion?
In this case, the generic name would be "SSL" (e.g. "SSL=openssl").
Prefixing a generic name with "COMPILE_[TSS|CC|SSL]=<tag|commit>" would
indicate compiling the application from source.
I will take this suggestion, thanks for your comment.
Cheers,
Tianjia