On 2/25/20 12:00 PM, Jarkko Sakkinen wrote:
On Thu, Feb 13, 2020 at 03:23:28PM -0500, Stefan Berger wrote:
From: Stefan Berger <stefanb@xxxxxxxxxxxxx>
Implement tpm2_init() that gets the TPM 2 timeouts and command durations
and command code attributes. This function is to be called in case the
TPM_OPS_AUTO_STARTUP flag is not set and therefore tpm2_auto_startup()
is not called.
Signed-off-by: Stefan Berger <stefanb@xxxxxxxxxxxxx>
The commit makes zero effort trying to explain what the heck tpm_init()
is and when it should be used and why the function name tpm2_init().
Are you saying the explanation of when to use tpm2_init above is not
enough? 'bviously we are trying to cover the case of using the TPM 2 by
a driver that doesn't use the TPM_OPS_AUTO_STARTUP flag and therefore
the TPM 2 timeouts and command durations and command code attributes are
not set as they would be if tpm2_auto_startup() was to be called and
tpm2_init() is the alternative to call. I didn't like tpm2_init()
either... any suggestions for a better name?
Stefan
/Jarkko