On Fri, 2019-07-12 at 13:49 +0200, Arnd Bergmann wrote: > A last minute change must have confused PTR_ERR() and ERR_PTR(): > > drivers/char/tpm/tpm_ftpm_tee.c:236:15: error: incompatible pointer to integer > conversion passing 'struct tee_context *' to parameter of type 'long' [- > Werror,-Wint-conversion] > if (ERR_PTR(pvt_data->ctx) == -ENOENT) > drivers/char/tpm/tpm_ftpm_tee.c:239:18: error: incompatible pointer to integer > conversion passing 'struct tee_context *' to parameter of type 'long' [- > Werror,-Wint-conversion] > return ERR_PTR(pvt_data->ctx); > > Fixes: c975c3911cc2 ("fTPM: firmware TPM running in TEE") > Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx> Arnd, thanks. I squashed this to the associated commit. I also fine-tuned the commit messages a bit (tag, imperative form). Started also wondering tha tpm_ftpm_tee is a too generic name given that this is for ARM TZ only. Would it make sense to rename it as something like tpm_ftpm_tee_arm? Other proposals are welcome. Just made something up. /Jarkko