On Sat, 2019-06-29 at 11:01 -0400, Sasha Levin wrote: > On Thu, Jun 27, 2019 at 02:31:35AM +0300, Jarkko Sakkinen wrote: > > On Tue, 2019-06-25 at 16:13 -0400, Sasha Levin wrote: > > > +static const uuid_t ftpm_ta_uuid = > > > + UUID_INIT(0xBC50D971, 0xD4C9, 0x42C4, > > > + 0x82, 0xCB, 0x34, 0x3F, 0xB7, 0xF3, 0x78, 0x96); > > > + > > > +/** > > > + * ftpm_tee_tpm_op_recv - retrieve fTPM response. > > > + * > > > > Should not have an empty line here. > > > > > + * @chip: the tpm_chip description as specified in driver/char/tpm/tpm.h. > > > + * @buf: the buffer to store data. > > > + * @count: the number of bytes to read. > > Jarkko, w.r.t your comment above, there is an empty line between the > function name and variables in drivers/char/tpm, and in particular > tpm_crb.c which you authored and I used as reference. Do you want us to > diverge here? There is divergence and that was the first thing I've contributed to the TPM driver. I use this as the reference for formatting function descriptions these days: https://www.kernel.org/doc/Documentation/kernel-doc-nano-HOWTO.txt According to that the legit way to format would be: * ftpm_tee_tpm_op_recv() - retrieve fTPM response. * @chip: the tpm_chip description as specified in driver/char/tpm/tpm.h. * @buf: the buffer to store data. * @count: the number of bytes to read. Since it is both a callback to an interface defined elsewhere and a static function and it does not document anything useful, I would just remove this comment. I'd do it for all callbacks that are part of tpm_call_ops. /Jarkko