Re: [PATCH v6 7/7] tpm: pass an array of tpm_bank_list structures to tpm_pcr_extend()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Dec 06, 2018 at 07:09:48PM +0100, Roberto Sassu wrote:
> 
> 
> On 12/5/2018 1:14 AM, Jarkko Sakkinen wrote:
> > On Tue, Dec 04, 2018 at 09:21:38AM +0100, Roberto Sassu wrote:
> > > The new tpm_bank_list structure has been preferred to the tpm_digest
> > > structure, to let the caller specify the size of the digest (which may be
> > > unknown to the TPM driver).
> > 
> > Why is that? Didn't previous commit query these?
> > 
> > > +struct tpm_bank_list {
> > > +	u16 alg_id;
> > > +	u16 extend_size;
> > > +	const u8 *extend_array;
> > > +};
> > 
> > Naming is not good here. If this only for extending shouldn't that
> > be in the structs name?
> 
> tpm_extend_input?

I think something like this would be appropriate:

struct tpm_extend_digest {
	u16 alg_id;
	u16 size;
	u8 *data;
};

/Jarkko



[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [Linux Kernel]     [Linux Kernel Hardening]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux SCSI]

  Powered by Linux