On 11/17/18 11:48 PM, Jarkko Sakkinen wrote: >> + if (priv->transmit_result || priv->partial_data) { >> + if (*off == 0) >> + priv->partial_data = priv->transmit_result; >> + >> + ret_size = min_t(ssize_t, size, priv->partial_data); >> + if (ret_size <= 0) { > When ret_size < 0? Shouldn't this be just "if (!ret_size)"? What we want to check here is if ret_size is positive, which is a valid value, or if it is negative or zero, which is an invalid value, so in this case (!ret_size) will not work. > >> /* Holds the resul of the last successful call to tpm_transmit() */ >> size_t transmit_result; >> + /* Holds the count how much of the response is still unread */ >> + size_t partial_data; > I'm otherwise happy how this look like but why call it partial_data. > You cannot really tell from the name anything about its contents as > data is very abstract term. so I will rename these two to response_length and response_length_rem, how does this sound? > BTW, why you need the new variable anyway and not just decrease the > variable where the length is original stored? We need to have two variables, otherwise how do we tell if some part of response was consumed to allow sending a new command? The transmit_result is used for that. If it is zero then one can transmit a new command even if the whole response is not consumed. The new variable tracks how much of the response is still to be read. Thanks, -- Tadeusz