On 2018-05-18 10:52, Stefan Berger wrote: > On 05/18/2018 10:39 AM, Mimi Zohar wrote: > > On Fri, 2018-05-18 at 09:54 -0400, Stefan Berger wrote: > > > On 05/18/2018 08:53 AM, Mimi Zohar wrote: > > [..] > > > > > > > > > If so, which ones? We could probably refactor the current > > > > > > > integrity_audit_message() and have ima_parse_rule() call into it to get > > > > > > > those fields as well. I suppose adding new fields to it wouldn't be > > > > > > > considered breaking user space? > > > > > > Changing the order of existing fields or inserting fields could break > > > > > > stuff and is strongly discouraged without a good reason, but appending > > > > > > fields is usually the right way to add information. > > > > > > > > > > > > There are exceptions, and in this case, I'd pick the "more standard" of > > > > > > the formats for AUDIT_INTEGRITY_RULE (ima_audit_measurement?) and stick > > > > > > with that, abandoning the other format, renaming the less standard > > > > > > version of the record (ima_parse_rule?) and perhpas adopting that > > > > > > abandonned format for the new record type while using > > > > > > current->audit_context. > > > > This sounds right, other than "type=INTEGRITY_RULE" (1805) for > > > > ima_audit_measurement(). Could we rename type=1805 to be > > > So do we want to change both? I thought that what > > > ima_audit_measurement() produces looks ok but may not have a good name > > > for the 'type'. Now in this case I would not want to 'break user space'. > > > The only change I was going to make was to what ima_parse_rule() produces. > > The only change for now is separating the IMA policy rules from the > > IMA-audit messages. > > > > Richard, when the containerid is appended to the IMA-audit messages, > > would we make the audit type name change then? > > > > > > INTEGRITY_AUDIT or INTEGRITY_IMA_AUDIT? The new type=1806 audit > > > > message could be named INTEGRITY_RULE or, if that would be confusing, > > > > INTEGRITY_POLICY_RULE. > > > For 1806, as we would use it in ima_parse_rule(), we could change that > > > in your patch to INTEGRITY_POLICY_RULE. IMA_POLICY_RULE may be better > > > for IMA to produce but that's inconsistent then. > > Ok > > One other question is whether IMA's audit calls should all adhere to > CONFIG_INTEGRITY_AUDIT. If I understand your question correctly, then no, since each one is a different type of record, hence the half dozen IMA record types: #define AUDIT_INTEGRITY_DATA 1800 /* Data integrity verification */ #define AUDIT_INTEGRITY_METADATA 1801 /* Metadata integrity verification */ #define AUDIT_INTEGRITY_STATUS 1802 /* Integrity enable status */ #define AUDIT_INTEGRITY_HASH 1803 /* Integrity HASH type */ #define AUDIT_INTEGRITY_PCR 1804 /* PCR invalidation msgs */ #define AUDIT_INTEGRITY_RULE 1805 /* policy rule */ > Most do but those two that currently use > AUDIT_INTEGRITY_RULE do not. Should that be changed as well? As far as I can tell, all the other IMA audit record types are fine. > Stefan - RGB -- Richard Guy Briggs <rgb@xxxxxxxxxx> Sr. S/W Engineer, Kernel Security, Base Operating Systems Remote, Ottawa, Red Hat Canada IRC: rgb, SunRaycer Voice: +1.647.777.2635, Internal: (81) 32635