On Fri, 2018-03-16 at 13:58 +0200, Jarkko Sakkinen wrote: > On Sat, 2018-03-10 at 14:14 -0800, James Bottomley wrote: > > TPM_BUF_OVERFLOW = BIT(0), > > + TPM_BUF_2B = BIT(1), > > Instead of re-using this I would prefer to have another enum for > buffer type. tpm_buf_init() could have the signature: > > int tpm_buf_init(unsigned int type); > > For commands there should be a function: > > void tpm_buf_set_command_header(struct tpm_buf *buf, u16 tag, u32 ordinal); > > And tpm_buf_append_2b() should not exist at all. It should be > maintained automatically by other append commands. Can you send the next version this patch as a separate entity? Once I can land this we have kind of stable ground for the following patches. After that it is easier test and review them. /Jarkko