On Fri, Feb 14, 2025 at 12:49:53PM +0100, mathieu.dubois-briand@xxxxxxxxxxx wrote: > From: Kamel Bouhara <kamel.bouhara@xxxxxxxxxxx> > > Add driver for Maxim Integrated MAX7360 PWM controller, supporting up to > 8 independent PWM outputs. ... + bits.h + dev_printk.h > +#include <linux/err.h> > +#include <linux/math.h> Other way around, id est you need math64.h (see below). > +#include <linux/mfd/max7360.h> + minmax.h > +#include <linux/mod_devicetable.h> > +#include <linux/module.h> > +#include <linux/of.h> Is this used? Cargo cult? > +#include <linux/platform_device.h> > +#include <linux/pwm.h> > +#include <linux/regmap.h> + types.h ... > +#define MAX7360_PWM_PERIOD_NS 2000000 /* 500 Hz */ Comment is superfluous, if you need HZ units, define the respective one. Also you can use something like (2 * NSEC_PER_MSEC) which will immediately gives a hint of how long this is and reduces potential 0:s miscalculations. This will need time.h ... > +#define MAX7360_PWM_CTRL_ENABLE(n) BIT(n) > +#define MAX7360_PWM_PORT(n) BIT(n) Personally I find these macros overkill. The value of them much shorter and equally readable. ... > +struct max7360_pwm { > + struct device *parent; Is it not the same as you can derive from regmap? > + struct regmap *regmap; Btw, have you checked the code generation if you place regmap the first in the structure? It might affect it. > +}; ... > + /* > + * Ignore user provided values for period_length_ns and duty_offset_ns: > + * we only support fixed period of MAX7360_PWM_PERIOD_NS and offset of > + * 0. Easy to read with 0 be on previous line. > + */ > + No need for this blank line. > + duty_steps = mul_u64_u64_div_u64(wf->duty_length_ns, MAX7360_PWM_MAX_RES, > + MAX7360_PWM_PERIOD_NS); This comes from math64.h > + > + wfhw->duty_steps = min(MAX7360_PWM_MAX_RES, duty_steps); ... > +static int max7360_pwm_write_waveform(struct pwm_chip *chip, > + struct pwm_device *pwm, > + const void *_wfhw) > +{ > + const struct max7360_pwm_waveform *wfhw = _wfhw; > + struct max7360_pwm *max7360_pwm; > + unsigned int val; > + int ret; > + > + max7360_pwm = max7360_pwm_from_chip(chip); > + > + val = (wfhw->duty_steps == 0) ? 0 : MAX7360_PWM_CTRL_ENABLE(pwm->hwpwm); > + ret = regmap_write_bits(max7360_pwm->regmap, MAX7360_REG_GPIOCTRL, > + MAX7360_PWM_CTRL_ENABLE(pwm->hwpwm), val); > + > + if (!ret && wfhw->duty_steps != 0) { > + ret = regmap_write(max7360_pwm->regmap, MAX7360_REG_PWM(pwm->hwpwm), > + wfhw->duty_steps); > + } > + > + return ret; Please, improve readability by rewriting like this: ret = regmap_write_bits(max7360_pwm->regmap, MAX7360_REG_GPIOCTRL, MAX7360_PWM_CTRL_ENABLE(pwm->hwpwm), val); if (ret) return ret; if (wfhw->duty_steps) return regmap_write(max7360_pwm->regmap, MAX7360_REG_PWM(pwm->hwpwm), wfhw->duty_steps); return 0; > +} ... > +static int max7360_pwm_probe(struct platform_device *pdev) > +{ With struct device *dev = &pdev->dev; all below will look shorter and nicer. > + struct max7360_pwm *max7360_pwm; > + struct pwm_chip *chip; > + int ret; > + > + if (!pdev->dev.parent) > + return dev_err_probe(&pdev->dev, -ENODEV, "no parent device\n"); > + > + chip = devm_pwmchip_alloc(pdev->dev.parent, MAX7360_NUM_PWMS, > + sizeof(*max7360_pwm)); > + if (IS_ERR(chip)) > + return PTR_ERR(chip); > + chip->ops = &max7360_pwm_ops; > + > + max7360_pwm = max7360_pwm_from_chip(chip); > + max7360_pwm->parent = pdev->dev.parent; > + > + max7360_pwm->regmap = dev_get_regmap(pdev->dev.parent, NULL); > + if (!max7360_pwm->regmap) > + return dev_err_probe(&pdev->dev, -ENODEV, > + "could not get parent regmap\n"); Will become one line (with the above suggestion). > + ret = devm_pwmchip_add(&pdev->dev, chip); > + if (ret != 0) Please, be consistent with the style, and moreover this style is unusual. > + return dev_err_probe(&pdev->dev, ret, > + "failed to add PWM chip\n"); > + > + return 0; > +} -- With Best Regards, Andy Shevchenko