On Mon, Jul 01, 2024 at 10:28:09PM +0200, Uwe Kleine-König wrote: > Hello Dmitry, > > $Subject ~= s/iI/I/ Oops, vim strikes again ;) > > > > static int adp5588_gpio_direction_output(struct gpio_chip *chip, > > @@ -310,9 +296,9 @@ static int adp5588_gpio_direction_output(struct gpio_chip *chip, > > struct adp5588_kpad *kpad = gpiochip_get_data(chip); > > unsigned int bank = ADP5588_BANK(kpad->gpiomap[off]); > > unsigned int bit = ADP5588_BIT(kpad->gpiomap[off]); > > - int ret; > > + int error; > > If you keep ret it's consistent with the other functions in this driver > (at least the one you touched above). This is part of my quest to have variables that hold error codes (i.e. when we do not return them in case of success) to be called "error". "ret" or "retval" is to be used when it is returned in both error and success cases; before the guard notation we needed to use the same variable in both success and failure. > > Otherwise looks fine to me, Thanks for the review! -- Dmitry