Hi, On 12/4/23 11:15, Shyam Sundar S K wrote: > From: Basavaraj Natikar <Basavaraj.Natikar@xxxxxxx> > > AMDSFH has information about the Ambient light via the Ambient > Light Sensor (ALS) which is part of the AMD sensor fusion hub. > Add PMF and AMDSFH interface to get this information. > > Reviewed-by: Mario Limonciello <mario.limonciello@xxxxxxx> > Co-developed-by: Shyam Sundar S K <Shyam-sundar.S-k@xxxxxxx> > Signed-off-by: Shyam Sundar S K <Shyam-sundar.S-k@xxxxxxx> > Signed-off-by: Basavaraj Natikar <Basavaraj.Natikar@xxxxxxx> > --- > drivers/hid/amd-sfh-hid/amd_sfh_common.h | 1 + > drivers/hid/amd-sfh-hid/sfh1_1/amd_sfh_init.c | 6 ++++++ > .../amd-sfh-hid/sfh1_1/amd_sfh_interface.c | 19 +++++++++++++++++++ > drivers/platform/x86/amd/pmf/spc.c | 9 ++++++++- > include/linux/amd-pmf-io.h | 4 ++++ > 5 files changed, 38 insertions(+), 1 deletion(-) Ok so with this patch also added in the mix I guess the multi-plexing nature of amd_get_sfh_info() makes sense, so it is ok to keep that. But this patch also needs to have its HID parts split out from the rest and the HID patches need to be merged separately. Since the merge-window is getting close I would like to propose the following: 1. Send a v7 addressing review remarks consisting of only patches 1-12, assuming all review remarks are fixed in v7 I can merge that then. 2. Send a 3 patch HID patch series separately: [PATCH 1/3] HID: amd_sfh: rename float_to_int() to amd_sfh_float_to_int() [PATCH 2/3] HID: amd_sfh: adding the HID hpd bits + amd_get_sfh_info() function [PATCH 3/3] HID: amd_sfh: adding the HID als bits 3. Once v7 of patches 1-12 + hopefully the 3 patch HID series have landed in 6.8-rc1 then I would be willing to take a patch using amd_get_sfh_info() to implement hpd + als support in the spc code as a fix for 6.8-rc# . Regards, Hans