On Sun, 09 Jul 2023, Linus Walleij wrote: > This converts the STMPE MFD device tree bindings to the YAML > schema. > > Reference the existing schema for the ADC, just define the > other subnode schemas directly in the MFD schema. > > Add two examples so we have examples covering both the simple > GPIO expander and the more complex with ADC and touchscreen. > > Some in-tree users do not follow the naming conventions for nodes > so these DTS files need to be augmented to use proper node names > like "adc", "pwm", "gpio", "keyboard-controller" etc before the > bindings take effect on them. > > Acked-by: Dmitry Torokhov <dmitry.torokhov@xxxxxxxxx> > Reviewed-by: Rob Herring <robh@xxxxxxxxxx> > Signed-off-by: Linus Walleij <linus.walleij@xxxxxxxxxx> > --- > This adds the missing GPIO bindings for the STMPE port expander > and converts the existing MFD binding to YAML. > > I suppose Lee can merge this when he's happy with it. > --- > Changes in v5: > - Rebase on v6.5-rc1 meaning GPIO binding is merged > upstream and can be dropped. > - Link to v4: https://lore.kernel.org/r/20230426-stmpe-dt-bindings-v4-0-36fdd53d9919@xxxxxxxxxx > > Changes in v4: > - Make the GPIO bindings a conversion: there were some old > text bindings for the STMPE GPIO, we now delete them as > part of the patch. > - I expect Lee or the DT binding tree to pick both patches. > - Link to v3: https://lore.kernel.org/r/20230426-stmpe-dt-bindings-v3-0-eac1d736e488@xxxxxxxxxx > > Changes in v3: > - Update to review feedback > - Collected some ack/review tags > - Link to v2: https://lore.kernel.org/r/20230426-stmpe-dt-bindings-v2-0-2f85a1fffcda@xxxxxxxxxx > > Changes in v2: > - Split off a separate GPIO binding > - Updated the MFD binding according to feedback > --- > ChangeLog v4->v5: > - Rebase on v6.5-rc1 > ChangeLog v3->v4: > - No changes. > ChangeLog v2->v3: > - Drop the required pwm properties already required by the > template pwm schema. > - Add the number of PWM cells as const. > ChangeLog v1->v2: > - Split off the GPIO bindings to their own schema, as the old > bindings didn't even have any GPIO bindings. Put the GPIO > schema before this schema so we can use GPIO in the examples. > - Drop nodename and pattern as STMPE is not a generic name. > - Add maxItems to the resets. > - Make wakeup-source just :true, as it is a generic property. > - Move unevaluatedProperties for subnodes right before properties > as requested. > - Name devices "port-expander" in the examples. > - Use lowercase hex in line init. > --- > .../devicetree/bindings/input/stmpe-keypad.txt | 41 --- > .../bindings/input/touchscreen/stmpe.txt | 108 -------- > .../devicetree/bindings/mfd/st,stmpe.yaml | 297 +++++++++++++++++++++ > Documentation/devicetree/bindings/mfd/stmpe.txt | 42 --- > 4 files changed, 297 insertions(+), 191 deletions(-) Applied, thanks -- Lee Jones [李琼斯]