On Wed, 7 Sep 2022, Bastien Nocera wrote: > > Export hid_match_id() so it can be used in device-specific drivers to > > implement their own matching with open-coding a match function. > > > > Signed-off-by: Bastien Nocera <hadess@xxxxxxxxxx> > > --- > > drivers/hid/hid-core.c | 1 + > > 1 file changed, 1 insertion(+) > > > > diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c > > index b7f5566e338d..72f8d8835b34 100644 > > --- a/drivers/hid/hid-core.c > > +++ b/drivers/hid/hid-core.c > > @@ -2088,6 +2088,7 @@ const struct hid_device_id *hid_match_id(const > > struct hid_device *hdev, > > > > return NULL; > > } > > +EXPORT_SYMBOL_GPL(hid_match_id); > > > > static const struct hid_device_id hid_hiddev_list[] = { > > { HID_USB_DEVICE(USB_VENDOR_ID_MGE, USB_DEVICE_ID_MGE_UPS) }, > > If those patches look good to you, would be great to get merged. > Benjamin doesn't have the bandwidth to test the patches on his own test > hardware right now, but I've been using them daily for a week now. Alright, I was waiting for Ack from Benjamin, but based on this, and due to the fact that I don't see any issue with it myself, I've now applied the series to for-6.1/logitech branch so that it gets as much linux-next exposure as possible. Thanks, -- Jiri Kosina SUSE Labs