On Thu, Mar 12, 2020 at 1:31 PM Harry Cutts <hcutts@xxxxxxxxxxxx> wrote: > > On Tue, 3 Mar 2020 at 16:21, Rajat Jain <rajatja@xxxxxxxxxx> wrote: > > > > New chromeos keyboards have a "snip" key that is basically a selective > > screenshot (allows a user to select an area of screen to be copied). > > Allocate a keyvode for it. > > > > Signed-off-by: Rajat Jain <rajatja@xxxxxxxxxx> > > --- > > V2: Drop patch [1/2] and instead rebase this on top of Linus' tree. > > > > include/uapi/linux/input-event-codes.h | 3 +++ > > 1 file changed, 3 insertions(+) > > > > diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h > > index 0f1db1cccc3fd..08c8572891efb 100644 > > --- a/include/uapi/linux/input-event-codes.h > > +++ b/include/uapi/linux/input-event-codes.h > > @@ -652,6 +652,9 @@ > > /* Electronic privacy screen control */ > > #define KEY_PRIVACY_SCREEN_TOGGLE 0x279 > > > > +/* Selective Screenshot */ > > +#define KEY_SNIP 0x280 > > + > > It's not very obvious to me what KEY_SNIP represents, without the > comment above. Maybe you could call it something like > KEY_SELECTIVE_SCREENSHOT, so that its purpose is more apparent to > someone seeing it in use. Sure, I do not have any preference, so I will change this to KEY_SELECTIVE_SCREENSHOT. Thanks, Rajat > > Harry Cutts > Chrome OS Touch/Input team > > > /* > > * Some keyboards have keys which do not have a defined meaning, these keys > > * are intended to be programmed / bound to macros by the user. For most > > -- > > 2.25.0.265.gbab2e86ba0-goog > >