Dear all, The purpose of this series is get rid of the remaining places where the cros_ec_cmd_xfer() function is used in favour of the cros_ec_cmd_xfer_status() helper. This allows us to make the cros_ec_cmd_xfer() function private and only expose to the users a single way to send commands to the Embedded Controller. With these changes we also want to help future improvements in the interface, like the Prashant's series (i.e [1]) to introduce a cros_ec_cmd() that will allow us to remove more duplicated code in different places. Best regards, Enric Note: Prashant, looks like you should fix your sendmail as the patches are not threaded. [1] https://lkml.org/lkml/2020/2/5/614 Enric Balletbo i Serra (8): platform/chrome: cros_ec_proto: Report command not supported Input: cros_ec_keyb: Use cros_ec_cmd_xfer_status helper platform/chrome: cros_ec_vbc: Use cros_ec_cmd_xfer_status helper platform/chrome: cros_ec_chardev: Use cros_ec_cmd_xfer_status helper platform/chrome: cros_ec_sysfs: Use cros_ec_cmd_xfer_status helper platform/chrome: cros_ec_lightbar: Use cros_ec_cmd_xfer_status helper platform/chrome: cros_ec: Use cros_ec_cmd_xfer_status helper platform/chrome: cros_ec_proto: Do not export cros_ec_cmd_xfer() drivers/input/keyboard/cros_ec_keyb.c | 14 +++--- drivers/platform/chrome/cros_ec.c | 2 +- drivers/platform/chrome/cros_ec_chardev.c | 2 +- drivers/platform/chrome/cros_ec_lightbar.c | 50 ++++++--------------- drivers/platform/chrome/cros_ec_proto.c | 14 ++++-- drivers/platform/chrome/cros_ec_sysfs.c | 36 +++++++-------- drivers/platform/chrome/cros_ec_vbc.c | 4 +- include/linux/platform_data/cros_ec_proto.h | 3 -- 8 files changed, 50 insertions(+), 75 deletions(-) -- 2.25.0