On Thu, Apr 27, 2017 at 02:22:36PM +0200, Martin Kepplinger wrote: > We now have a few of this device's definitions. Let's avoid magic numbers > and use them. > > Signed-off-by: Martin Kepplinger <martin.kepplinger@xxxxxxxxxxxxx> > --- > drivers/input/touchscreen/ar1021_i2c.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/input/touchscreen/ar1021_i2c.c b/drivers/input/touchscreen/ar1021_i2c.c > index 2a76231..edd5268 100644 > --- a/drivers/input/touchscreen/ar1021_i2c.c > +++ b/drivers/input/touchscreen/ar1021_i2c.c > @@ -44,7 +44,7 @@ static irqreturn_t ar1021_i2c_irq(int irq, void *dev_id) > goto out; > > /* sync bit set ? */ > - if ((data[0] & 0x80) == 0) > + if ((data[0] & AR1021_TOUCH) == 0) I'd rather have it as "(data & BIT(7))". This constant does not provide any better meaning than number 0x80. At least the latter shows that we test the MSB or the first byte, while the former obfuscates it. Thanks. -- Dmitry -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html