Looking at the API, I really don't like the mixing of namespaces. Either it's fw_ or it's firmware_ but not a mix of both.
I agree, that was not really clever. struct fw_loading { ... } __fw_loading_*() fw_loading_*() Would that make more sense? firmware_loading_ as prefix is a bit long IMO.
Also looks like fw_loading_start() would do nothing as the struct is likely zero initialised, and FW_STATUS_LOADING == 0. Maybe you need an UNSET enum member?
Good point, I cut a corner here a bit :). In the spirit of making things more clear fw_loading_start() should be used.
FW_STATUS_ABORT <- FW_STATUS_ABORTED, to match the adjective suffixes of the other members. Ditto fw_loading_abort() which doesn't abort firmware loading but sets the status.
Okay. Thanks a lot for the feedback. cheers, daniel -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html