Hi On Sat, Jul 26, 2014 at 6:46 PM, Rickard Strandqvist <rickard_strandqvist@xxxxxxxxxxxxxxxxxx> wrote: > Replacing strncpy with strlcpy to avoid strings that lacks null terminate. > And removed unnecessary magic numbers. > > Signed-off-by: Rickard Strandqvist <rickard_strandqvist@xxxxxxxxxxxxxxxxxx> > --- > drivers/hid/uhid.c | 18 ++++++------------ > 1 file changed, 6 insertions(+), 12 deletions(-) > > diff --git a/drivers/hid/uhid.c b/drivers/hid/uhid.c > index 0cb92e3..b72ab0c 100644 > --- a/drivers/hid/uhid.c > +++ b/drivers/hid/uhid.c > @@ -392,12 +392,9 @@ static int uhid_dev_create(struct uhid_device *uhid, > goto err_free; > } > > - strncpy(hid->name, ev->u.create.name, 127); > - hid->name[127] = 0; > - strncpy(hid->phys, ev->u.create.phys, 63); > - hid->phys[63] = 0; > - strncpy(hid->uniq, ev->u.create.uniq, 63); > - hid->uniq[63] = 0; > + strlcpy(hid->name, ev->u.create.name, sizeof(hid->name)); > + strlcpy(hid->phys, ev->u.create.phys, sizeof(hid->phys)); > + strlcpy(hid->uniq, ev->u.create.uniq, sizeof(hid->uniq)); NAK, this patch is wrong. strlcpy() is *not* a replacement for strncpy(). Please see lib/string.c or the man-page of strlcpy(3). It calls strlen() on the source, which strncpy() does not. "ev" was copied unmodified from user-space and might not be NULL-terminated, therefore, strncpy() is the right choice. Btw., please avoid commit-messages that sound like bug-fixes, which this definitely is not. hid_allocate_device() cleans the object to ZERO, therefore, you're guaranteed that there's a proper NULL-terminator, independent of the contents of ev->u.xyz. Thanks David > hid->ll_driver = &uhid_hid_driver; > hid->bus = ev->u.create.bus; > @@ -452,12 +449,9 @@ static int uhid_dev_create2(struct uhid_device *uhid, > goto err_free; > } > > - strncpy(hid->name, ev->u.create2.name, 127); > - hid->name[127] = 0; > - strncpy(hid->phys, ev->u.create2.phys, 63); > - hid->phys[63] = 0; > - strncpy(hid->uniq, ev->u.create2.uniq, 63); > - hid->uniq[63] = 0; > + strlcpy(hid->name, ev->u.create2.name, sizeof(hid->name)); > + strlcpy(hid->phys, ev->u.create2.phys, sizeof(hid->phys)); > + strlcpy(hid->uniq, ev->u.create2.uniq, sizeof(hid->uniq)); > > hid->ll_driver = &uhid_hid_driver; > hid->bus = ev->u.create2.bus; > -- > 1.7.10.4 > -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html