On Fri, 2014-04-25 at 21:43 -0700, Dmitry Torokhov wrote: > On Fri, Apr 25, 2014 at 07:22:16PM +0300, Andy Shevchenko wrote: > > This makes the error handling much more simpler than open-coding everything and > > in addition makes the probe function smaller an tidier. [] > > - pdata = kzalloc(sizeof(*pdata) + nbuttons * (sizeof *button), > > - GFP_KERNEL); > > - if (!pdata) { > > - error = -ENOMEM; > > - goto err_out; > > - } > > + pdata = devm_kzalloc(dev, sizeof(*pdata), GFP_KERNEL); > > + if (!pdata) > > + return ERR_PTR(-ENOMEM); > > + > > + pdata->buttons = devm_kcalloc(dev, nbuttons, sizeof (*button), > > + GFP_KERNEL); > > + if (!pdata->buttons) > > + return ERR_PTR(-ENOMEM); > > Why are we splitting the allocation in 2? Just for logical distinguishing, but I'm okay with one allocation. -- Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> Intel Finland Oy -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html