Re: [PATCH v2 0/9] HID: spring cleanup v2

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi David,

On Wed, Feb 12, 2014 at 5:13 AM, David Herrmann <dh.herrmann@xxxxxxxxx> wrote:
> Hi
>
> On Wed, Feb 5, 2014 at 10:33 PM, Benjamin Tissoires
> <benjamin.tissoires@xxxxxxxxxx> wrote:
>> Hi guys,
>>
>> well, here comes the promised v2 of the ll_transport cleanup.
>>
>> As I said, I removed patches which need some more work, and kept only the
>> trivial ones. I also added David's documentation, which gives us a net
>> difference of +210 lines of code :(
>> Let's say that we still have a net worth of -106 lines of actual code :)
>>
>> Cheers,
>> Benjamin
>>
>> Changes since v1:
>> - removed uhid, i2c-hid patches
>> - removed the previous 11/11 (move hid_output_raw_report to hid_ll_driver)
>> - hid-logitech-dj: use hid_hw_raw_request instead of hid_output_report (2/9)
>> - add documentation - I removed the hid_input_event() doc (9/9)
>>
>> Benjamin Tissoires (9):
>>   HID: add inliners for ll_driver transport-layer callbacks
>>   HID: logitech-dj: remove hidinput_input_event
>
> Apart from this logitech-dj patch, which I feel uncomfortable with
> reviewing if I don't have the hardware, this series looks really good.
> I think all patches already carry my r-b, otherwise feel free to add
> them.

Thanks a lot for the review!

I tested the logitech one with a TK820 which has a LED on the
capslock, and it's working fine. Still adding Nestor in the loop if he
manages to find some time to review it.

Nestor, could you have a look at 2/9
(https://patchwork.kernel.org/patch/3591381/)?

Cheers,
Benjamin

>
> Thanks a lot for the cleanup!
> David
>
>>   HID: HIDp: remove hidp_hidinput_event
>>   HID: remove hidinput_input_event handler
>>   HID: HIDp: remove duplicated coded
>>   HID: usbhid: remove duplicated code
>>   HID: remove hid_get_raw_report in struct hid_device
>>   HID: introduce helper to access hid_output_raw_report()
>>   HID: Add HID transport driver documentation
>>
>>  Documentation/hid/hid-transport.txt | 316 ++++++++++++++++++++++++++++++++++++
>>  drivers/hid/hid-input.c             |  12 +-
>>  drivers/hid/hid-lg.c                |   6 +-
>>  drivers/hid/hid-logitech-dj.c       | 106 +++++-------
>>  drivers/hid/hid-magicmouse.c        |   2 +-
>>  drivers/hid/hid-sony.c              |   9 +-
>>  drivers/hid/hid-thingm.c            |   4 +-
>>  drivers/hid/hid-wacom.c             |  16 +-
>>  drivers/hid/hid-wiimote-core.c      |   2 +-
>>  drivers/hid/hidraw.c                |   9 +-
>>  drivers/hid/i2c-hid/i2c-hid.c       |   1 -
>>  drivers/hid/uhid.c                  |   1 -
>>  drivers/hid/usbhid/hid-core.c       |  65 ++------
>>  include/linux/hid.h                 |  68 +++++++-
>>  net/bluetooth/hidp/core.c           | 115 ++-----------
>>  15 files changed, 471 insertions(+), 261 deletions(-)
>>  create mode 100644 Documentation/hid/hid-transport.txt
>>
>> --
>> 1.8.3.1
>>
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Media Devel]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Linux Wireless Networking]     [Linux Omap]

  Powered by Linux