On Wed, Apr 25, 2012 at 06:14:16PM -0700, Ping Cheng wrote: > Main part of patch is adding support for a new Wacom MT touch > packet and labels these devices using MTSCREEN type. > > Other items of interest: > > Delete some duplicate code in HID parsing for Y info since > its already done in X path. > > In wacom_query_tablet_data(), only invoke the set report > that requests tablets to send Wacom Touch packets for > Finger interfaces. Mostly, this is to make code intent clear. Applied, but: > + > + wacom->num_contacts_left -= contacts_to_send; > + if (wacom->num_contacts_left < 0) > + wacom->num_contacts_left = 0; num_contacts_left is unsigned so this condition woudl never fire. Changed num_contacts_left to be signed before applying. Thanks. -- Dmitry -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html