On Mon, Dec 5, 2011 at 7:13 PM, Axel Lin <axel.lin@xxxxxxxxx> wrote: > Since commit 6384fd "ARM: pxa: rename IRQ_GPIO to PXA_GPIO_TO_IRQ", > I got below buid errors due to implicit declaration of function 'IRQ_GPIO'. > > Use common gpio_to_irq() to replace machine dependant macro IRQ_GPIO(). > > CC drivers/input/touchscreen/zylonite-wm97xx.o > drivers/input/touchscreen/zylonite-wm97xx.c: In function 'zylonite_wm97xx_probe': > drivers/input/touchscreen/zylonite-wm97xx.c:195: error: implicit declaration of function 'IRQ_GPIO' > make[3]: *** [drivers/input/touchscreen/zylonite-wm97xx.o] Error 1 > make[2]: *** [drivers/input/touchscreen] Error 2 > make[1]: *** [drivers/input] Error 2 > make: *** [drivers] Error 2 > > Cc: Mark Brown <broonie@xxxxxxxxxxxxxxxxxxxxxxxxxxx> > Cc: Haojian Zhuang <haojian.zhuang@xxxxxxxxxxx> > Signed-off-by: Axel Lin <axel.lin@xxxxxxxxx> > --- > I got the build error in linux-next tree, > thus this patch is against linux-next (20111205). > > Axel > drivers/input/touchscreen/zylonite-wm97xx.c | 5 +++-- > 1 files changed, 3 insertions(+), 2 deletions(-) > > diff --git a/drivers/input/touchscreen/zylonite-wm97xx.c b/drivers/input/touchscreen/zylonite-wm97xx.c > index add6e3b..bf0869a7 100644 > --- a/drivers/input/touchscreen/zylonite-wm97xx.c > +++ b/drivers/input/touchscreen/zylonite-wm97xx.c > @@ -22,6 +22,7 @@ > #include <linux/kernel.h> > #include <linux/init.h> > #include <linux/delay.h> > +#include <linux/gpio.h> > #include <linux/irq.h> > #include <linux/interrupt.h> > #include <linux/io.h> > @@ -192,8 +193,8 @@ static int zylonite_wm97xx_probe(struct platform_device *pdev) > else > gpio_touch_irq = mfp_to_gpio(MFP_PIN_GPIO26); > > - wm->pen_irq = IRQ_GPIO(gpio_touch_irq); > - irq_set_irq_type(IRQ_GPIO(gpio_touch_irq), IRQ_TYPE_EDGE_BOTH); > + wm->pen_irq = gpio_to_irq(gpio_touch_irq); > + irq_set_irq_type(wm->pen_irq, IRQ_TYPE_EDGE_BOTH); > > wm97xx_config_gpio(wm, WM97XX_GPIO_13, WM97XX_GPIO_IN, > WM97XX_GPIO_POL_HIGH, > -- Acked-by: Haojian Zhuang <haojian.zhuang@xxxxxxxxx> -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html