Hi Gabor, On Tue, Nov 30, 2010 at 1:44 PM, Gabor Juhos <juhosg@xxxxxxxxxxx> wrote: > This set contains my latest fixes on top of Dmitry's changes. > > Gabor Juhos (8): > input: gpio_keys_polled: add MODULE_ALIAS > input: gpio_keys_polled: return -EINVAL if wakeup specified > input: gpio_keys_polled: avoid possible division by zero Good idea to return -EINVAL in those cases. > input: gpio_keys_polled: use DIV_ROUND_UP to compute the threshold value That's what I was looking for, thank you for fixing that up. > input: gpio_keys_polled: precompute threshold value in the probe routine Even better. > input: gpio_keys_polled: use tabs instead of spaces for indentation > input: gpio_keys_polled: remove a local variable > input: gpio_keys_polled: fix Kconfig help text I missed that remaining gpio-buttons reference, thanks for catching that. > drivers/input/keyboard/Kconfig | 4 +- > drivers/input/keyboard/gpio_keys_polled.c | 30 +++++++++++++++------------- > 2 files changed, 18 insertions(+), 16 deletions(-) I have tested this series with the "da850-evm: add gpio-{keys,leds} for UI and BB expanders" on top of your "[PATCH 09/18] input: add input driver for polled GPIO buttons" patch, my "[PATCH WIP 0/6] suggested changes to gpio_buttons driver" series and Dmitry's "Input: gpio-buttons - misc changes" patch. Only minimal changes were needed in the later patches of the da850-evm series. They can be summarized by: s/gpio_keys_polled\.h/gpio_keys.\h/g and s/gpio_keys_polled_platform_data/gpio_keys_platform_data/g. With those changes I observed the expected input events with evtest. Tested-by: Ben Gardiner <bengardiner@xxxxxxxxxxxxxx> Best Regards, Ben Gardiner --- Nanometrics Inc. http://www.nanometrics.ca -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html