Hi Jani, On Thu, Oct 22, 2009 at 12:32:20PM +0300, Jani Nikula wrote: > From: Jani Nikula <ext-jani.1.nikula@xxxxxxxxx> > > Signed-off-by: Jani Nikula <ext-jani.1.nikula@xxxxxxxxx> > --- > include/linux/input.h | 5 +++++ > 1 files changed, 5 insertions(+), 0 deletions(-) > > diff --git a/include/linux/input.h b/include/linux/input.h > index 0ccfc30..3c246b1 100644 > --- a/include/linux/input.h > +++ b/include/linux/input.h > @@ -595,6 +595,8 @@ struct input_absinfo { > #define KEY_NUMERIC_STAR 0x20a > #define KEY_NUMERIC_POUND 0x20b > > +#define KEY_CAMERA_FOCUS 0x210 I believe that this has already been discussed and I am OK with adding such keycode, as long and there are in-kernel users. > + > /* We avoid low common keys in module aliases so they don't get huge. */ > #define KEY_MIN_INTERESTING KEY_MUTE > #define KEY_MAX 0x2ff > @@ -677,6 +679,9 @@ struct input_absinfo { > #define SW_LINEOUT_INSERT 0x06 /* set = inserted */ > #define SW_JACK_PHYSICAL_INSERT 0x07 /* set = mechanical switch set */ > #define SW_VIDEOOUT_INSERT 0x08 /* set = inserted */ > +#define SW_CAMERA_LENSE_COVER 0x09 /* set = lense covered */ > +#define SW_KEYPAD_SLIDE 0x0a /* set = keypad slide out */ > +#define SW_PROXIMITY 0x0b /* set = proximity sensor covered */ Don't quite like the name for this one, any alternatives? > #define SW_MAX 0x0f > #define SW_CNT (SW_MAX+1) > Thanks. -- Dmitry -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html