Re: [PATCH] sh: maple: Add support for VMU devices (v2) [1/3]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Monday 02 February 2009 19:17:43 Adrian McMenamin wrote:
> +	if (src_ofs >= ((card->parts)[partition]).numblocks * card->blocklen)
> +	if (num > ((card->parts)[partition]).numblocks)
> +	pcache = (card->parts[partition]).pcache;

ive only quoted some, but the use of parenthesis here is pointless and imo 
makes the code harder to read.  it's like trying to parse lisp ;).

> +	vblock = kmalloc(sizeof(struct vmu_block), GFP_KERNEL);

sizeof(*vblock) ?

> +static int __init vmu_flash_map_init(void)
> +{
> +	maple_driver_register(&vmu_flash_driver);
> +	return 0;
> +}

shouldnt this be:
	return maple_driver_register(&vmu_flash_driver);
-mike

Attachment: signature.asc
Description: This is a digitally signed message part.


[Index of Archives]     [Linux Media Devel]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Linux Wireless Networking]     [Linux Omap]

  Powered by Linux