[PATCH 0/2] iio:trigger: Remove re-poll logic.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>

This code isn't used by any current mainline drivers (except
via error handling routes that shouldn't exist).  The original
user is long gone.  It is causing issues, so let's drop it.

The main bulk of this mini-series is renaming the function to account
for the change in what it does.

Lars, what impact does doing this have on your patches to mark hrtimer
and irq_work as expiring in hardirq context? I got a bit lost in the
discussion of that series, beyond figuring out his corner needed cleaning up.

Jonathan Cameron (2):
  iio: Fix: Do not poll the driver again if try_reenable() callback
    returns non 0.
  iio:trigger: rename try_reenable() to reenable() plus return void

 drivers/iio/accel/bma180.c             |  9 ++++++---
 drivers/iio/accel/bmc150-accel-core.c  | 12 ++++--------
 drivers/iio/accel/kxcjk-1013.c         | 10 +++-------
 drivers/iio/accel/mxc4005.c            | 16 ++++++----------
 drivers/iio/adc/at91-sama5d2_adc.c     |  8 +++-----
 drivers/iio/gyro/adxrs290.c            |  6 ++----
 drivers/iio/gyro/bmg160_core.c         | 12 ++++--------
 drivers/iio/imu/kmx61.c                | 10 +++-------
 drivers/iio/industrialio-trigger.c     |  6 ++----
 drivers/iio/magnetometer/bmc150_magn.c | 10 +++++-----
 include/linux/iio/trigger.h            |  4 ++--
 11 files changed, 40 insertions(+), 63 deletions(-)

-- 
2.28.0




[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Input]     [Linux Kernel]     [Linux SCSI]     [X.org]

  Powered by Linux