On Mon, Mar 23, 2020 at 01:35:58AM +0200, Andy Shevchenko wrote: > On Sun, Mar 22, 2020 at 8:54 PM Deepak R Varma <mh12gx2825@xxxxxxxxx> wrote: > > > > Reformat pointer initialization to make it more readable as per the > > coding standards. Problem detected by checkpatch. > > > - struct imgu_v4l2_subdev *imgu_sd = > > - container_of(ctrl->handler, struct imgu_v4l2_subdev, ctrl_handler); > > + struct imgu_v4l2_subdev *imgu_sd = container_of(ctrl->handler, > > + struct imgu_v4l2_subdev, > > + ctrl_handler); > > I'm sorry I don't see benefit of this change, actually an opposite. Hello Andy, Thank you for your comment. To me, it helps quickly and clearly spot *imgu_sd. Also the initialization looks more structured. But that's just me. I will wait to see if anyone else wants to share their thoughts, and then circle back to you on next steps. Is that fine? Deepak. > > -- > With Best Regards, > Andy Shevchenko