On Wed, Mar 29, 2017 at 3:33 PM, simran singhal <singhalsimran0@xxxxxxxxx> wrote: > Use macro min() to get the minimum of two values for brevity and > readability. > > Signed-off-by: simran singhal <singhalsimran0@xxxxxxxxx> > --- > drivers/iio/common/st_sensors/st_sensors_i2c.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/iio/common/st_sensors/st_sensors_i2c.c b/drivers/iio/common/st_sensors/st_sensors_i2c.c > index c83df4d..7a68fdd 100644 > --- a/drivers/iio/common/st_sensors/st_sensors_i2c.c > +++ b/drivers/iio/common/st_sensors/st_sensors_i2c.c > @@ -39,7 +39,7 @@ static int st_sensors_i2c_read_byte(struct st_sensor_transfer_buffer *tb, > *res_byte = err & 0xff; > > st_accel_i2c_read_byte_error: > - return err < 0 ? err : 0; > + return min(err, 0); > } Appreciate the brevity but this certainly doesn't make code easier to read. In linux kernel err < 0 signifies an error and be replacing comparison < 0 with min() we some hide the meaning of this. thanks, Daniel. -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html