On Wed, Jul 24, 2024 at 02:45:36PM +0900, Damien Le Moal wrote: > Rename the function ata_dma_blacklisted() to ata_dev_nodma() as this new > name is more neutral. The function signature is also changed to return a > boolean instead of an int. > > Signed-off-by: Damien Le Moal <dlemoal@xxxxxxxxxx> > Reviewed-by: Igor Pylypiv <ipylypiv@xxxxxxxxxx> > --- > drivers/ata/libata-core.c | 15 ++++++++------- > 1 file changed, 8 insertions(+), 7 deletions(-) > > diff --git a/drivers/ata/libata-core.c b/drivers/ata/libata-core.c > index c7752dc80028..a35bce4236d3 100644 > --- a/drivers/ata/libata-core.c > +++ b/drivers/ata/libata-core.c > @@ -4287,16 +4287,17 @@ static unsigned long ata_dev_blacklisted(const struct ata_device *dev) > return 0; > } > > -static int ata_dma_blacklisted(const struct ata_device *dev) > +static bool ata_dev_nodma(const struct ata_device *dev) > { > - /* We don't support polling DMA. > - * DMA blacklist those ATAPI devices with CDB-intr (and use PIO) > - * if the LLDD handles only interrupts in the HSM_ST_LAST state. > + /* > + * We do not support polling DMA. Deny DMA for those ATAPI devices > + * with CDB-intr (and use PIO) if the LLDD handles only interrupts in > + * the HSM_ST_LAST state. > */ > if ((dev->link->ap->flags & ATA_FLAG_PIO_POLLING) && > (dev->flags & ATA_DFLAG_CDB_INTR)) > - return 1; > - return (dev->horkage & ATA_HORKAGE_NODMA) ? 1 : 0; > + return true; > + return dev->horkage & ATA_HORKAGE_NODMA; > } > > /** > @@ -4404,7 +4405,7 @@ static void ata_dev_xfermask(struct ata_device *dev) > xfer_mask &= ~(0x03 << (ATA_SHIFT_MWDMA + 3)); > } > > - if (ata_dma_blacklisted(dev)) { > + if (ata_dev_nodma(dev)) { > xfer_mask &= ~(ATA_MASK_MWDMA | ATA_MASK_UDMA); > ata_dev_warn(dev, > "device is on DMA blacklist, disabling DMA\n"); Nit: if you rename blacklist, perhaps you should rename/avoid it in the above print as well. Regardless: Reviewed-by: Niklas Cassel <cassel@xxxxxxxxxx>