Linus, The following changes since commit 568035b01cfb107af8d2e4bd2fb9aea22cf5b868: Linux 6.0-rc1 (2022-08-14 15:50:18 -0700) are available in the Git repository at: ssh://git@xxxxxxxxxxxxxxxxxxx/pub/scm/linux/kernel/git/dlemoal/libata tags/ata-6.1-rc1 for you to fetch changes up to 71d7b6e51ad3370d850303b61b79528fb2872f0a: ata: libata-eh: avoid needless hard reset when revalidating link (2022-09-24 15:31:00 +0900) ---------------------------------------------------------------- ata changes for 6.1-rc1 * Print the timeout value for internal command failures due to a timeout (from Tomas). * Improve parameter names in ata_dev_set_feature() to clarify this function use (from Niklas). * Improve the ahci driver low power mode setting initialization to allow more flexibility for the user (from Rafael). * Several patches to remove redundant variables in libata-core, libata-eh and the pata_macio driver and to fix typos in comments (from Jinpeng, Shaomin, Ye). * Some code simplifications and macro renaming (for clarity) in various functions of libata-core (from me). * Add a missing check for a potential failure of sata_scr_read() in sata_print_link_status() (from Li). * Cleanup of libata Kconfig PATA_PLATFORM and PATA_OF_PLATFORM options (from Lukas). * Cleanups of ata dt-bindings and improvements of libahci_platform, ahci and libahci code (from Serge) * New driver for Synopsys AHCI SATA controllers, based of the generic ahci code (from Serge). One compilation warning fix is added for this driver (from me). * Several fixes to macros used to discover a drive capabilities to be consistent with the ACS specifications (from Niklas). * A couple of simplifcations to some libata functions, removing unnecessary arguments (from Niklas). * An improvements to libata-eh code to avoid unnecessary link reset when revalidating a drive after a failed command. In practice, this extra, unneeded reset, reset does not cause any arm beyond slightly slowing down error recovery (from Niklas). ---------------------------------------------------------------- Damien Le Moal (5): ata: libata: Rename ATA_DFLAG_NCQ_PRIO_ENABLE ata: libata-core: Simplify ata_build_rw_tf() ata: libata-core: Simplify ata_dev_set_xfermode() ata: ahci_st: Fix compilation warning ata: ahci_st: Enable compile test Jinpeng Cui (1): ata: libata-core: remove redundant err_mask variable Li Zhong (1): ata: libata-core: Check errors in sata_print_link_status() Lukas Bulwahn (2): ata: clean up how architectures enable PATA_PLATFORM and PATA_OF_PLATFORM ata: make PATA_PLATFORM selectable only for suitable architectures Niklas Cassel (8): ata: libata-core: improve parameter names for ata_dev_set_feature() ata: fix ata_id_sense_reporting_enabled() and ata_id_has_sense_reporting() ata: fix ata_id_has_devslp() ata: fix ata_id_has_ncq_autosense() ata: fix ata_id_has_dipm() ata: libata: drop superfluous ata_eh_request_sense() parameter ata: libata: drop superfluous ata_eh_analyze_tf() parameter ata: libata-eh: avoid needless hard reset when revalidating link Rafael J. Wysocki (1): ata: ahci: Do not check ACPI_FADT_LOW_POWER_S0 Serge Semin (23): dt-bindings: ata: ahci-platform: Move dma-coherent to sata-common.yaml dt-bindings: ata: ahci-platform: Detach common AHCI bindings dt-bindings: ata: ahci-platform: Clarify common AHCI props constraints dt-bindings: ata: sata: Extend number of SATA ports dt-bindings: ata: sata-brcm: Apply common AHCI schema ata: libahci_platform: Convert to using platform devm-ioremap methods ata: libahci_platform: Convert to using devm bulk clocks API ata: libahci_platform: Sanity check the DT child nodes number ata: libahci_platform: Parse ports-implemented property in resources getter ata: libahci_platform: Introduce reset assertion/deassertion methods dt-bindings: ata: ahci: Add platform capability properties ata: libahci: Extend port-cmd flags set with port capabilities ata: libahci: Discard redundant force_port_map parameter ata: libahci: Don't read AHCI version twice in the save-config method ata: ahci: Convert __ahci_port_base to accepting hpriv as arguments ata: ahci: Introduce firmware-specific caps initialization dt-bindings: ata: ahci: Add DWC AHCI SATA controller DT schema ata: libahci_platform: Add function returning a clock-handle by id ata: ahci: Add DWC AHCI SATA controller support dt-bindings: ata: ahci: Add Baikal-T1 AHCI SATA controller DT schema ata: ahci-dwc: Add platform-specific quirks support ata: ahci-dwc: Add Baikal-T1 AHCI SATA interface support MAINTAINERS: Add maintainers for DWC AHCI SATA driver Shaomin Deng (2): ata: pata_macio: Remove unneeded word in comments ata: libata-sff: Fix double word in comments Tomas Henzl (1): ata: libata-core: Print timeout value when internal command times ye xingchen (1): ata: libata-eh: Remove the unneeded result variable .../devicetree/bindings/ata/ahci-common.yaml | 123 +++++ .../devicetree/bindings/ata/ahci-platform.yaml | 92 +--- .../devicetree/bindings/ata/baikal,bt1-ahci.yaml | 115 +++++ .../devicetree/bindings/ata/brcm,sata-brcm.yaml | 4 +- .../devicetree/bindings/ata/sata-common.yaml | 17 +- .../bindings/ata/snps,dwc-ahci-common.yaml | 102 +++++ .../devicetree/bindings/ata/snps,dwc-ahci.yaml | 75 ++++ MAINTAINERS | 9 + arch/arm/mach-versatile/Kconfig | 1 - arch/arm64/Kconfig | 1 - drivers/ata/Kconfig | 18 +- drivers/ata/Makefile | 1 + drivers/ata/ahci.c | 9 +- drivers/ata/ahci.h | 22 +- drivers/ata/ahci_da850.c | 47 +- drivers/ata/ahci_dm816.c | 4 +- drivers/ata/ahci_dwc.c | 493 +++++++++++++++++++++ drivers/ata/ahci_mtk.c | 2 - drivers/ata/ahci_platform.c | 5 - drivers/ata/ahci_st.c | 4 - drivers/ata/libahci.c | 63 ++- drivers/ata/libahci_platform.c | 218 ++++++--- drivers/ata/libata-core.c | 64 ++- drivers/ata/libata-eh.c | 38 +- drivers/ata/libata-sata.c | 6 +- drivers/ata/libata-scsi.c | 4 +- drivers/ata/libata-sff.c | 2 +- drivers/ata/libata.h | 7 +- drivers/ata/pata_macio.c | 3 +- include/dt-bindings/ata/ahci.h | 20 + include/linux/ahci_platform.h | 8 +- include/linux/ata.h | 39 +- include/linux/libata.h | 2 +- 33 files changed, 1331 insertions(+), 287 deletions(-) create mode 100644 Documentation/devicetree/bindings/ata/ahci-common.yaml create mode 100644 Documentation/devicetree/bindings/ata/baikal,bt1-ahci.yaml create mode 100644 Documentation/devicetree/bindings/ata/snps,dwc-ahci-common.yaml create mode 100644 Documentation/devicetree/bindings/ata/snps,dwc-ahci.yaml create mode 100644 drivers/ata/ahci_dwc.c create mode 100644 include/dt-bindings/ata/ahci.h