Hi Michael, On Sun, Jun 6, 2021 at 7:54 AM Michael Schmitz <schmitzmic@xxxxxxxxx> wrote: > Add code to support 10 Mbit and 100 Mbit mode for APNE driver. > > A new ISA type ISA_TYPE_AG100 switches the Amiga ISA inb accessor > to word access as required by the 100 Mbit cards. missing "dynamically". > > Patch modified after patch "[PATCH RFC net-next] Amiga PCMCIA > 100 MBit card support" submitted to netdev 2018/09/16 by Alex > Kazik <alex@xxxxxxxx>. > > Signed-off-by: Michael Schmitz <schmitzmic@xxxxxxxxx> Thanks for your patch! > --- a/arch/m68k/include/asm/io_mm.h > +++ b/arch/m68k/include/asm/io_mm.h > @@ -101,6 +101,11 @@ > #define ISA_TYPE_Q40 (1) > #define ISA_TYPE_AG (2) > #define ISA_TYPE_ENEC (3) > +#define ISA_TYPE_AG100 (4) /* for 100 MBit APNE card */ As this type may be needed for other cards, perhaps it should be named after what it really does, i.e. always using 16-bit accesses? ISA_TYPE_AG16? > + > +#if defined(CONFIG_APNE100MBIT) #ifdef > +#define MULTI_ISA 1 > +#endif > > #if defined(CONFIG_Q40) && !defined(MULTI_ISA) > #define ISA_TYPE ISA_TYPE_Q40 > @@ -135,6 +140,9 @@ static inline u8 __iomem *isa_itb(unsigned long addr) > #ifdef CONFIG_Q40 > case ISA_TYPE_Q40: return (u8 __iomem *)Q40_ISA_IO_B(addr); > #endif > +#if defined(CONFIG_APNE100MBIT) #ifdef > + case ISA_TYPE_AG100: fallthrough; Fallthrough to what? Oh, to ISA_TYPE_AG. Please make this clear, and safer, by moving this inside the #ifdef below (CONFIG_APNE100MBIT depends on CONFIG_AMIGA_PCMCIA). > +#endif > #ifdef CONFIG_AMIGA_PCMCIA > case ISA_TYPE_AG: return (u8 __iomem *)AG_ISA_IO_B(addr); > #endif > @@ -212,13 +232,16 @@ static inline u16 __iomem *isa_mtw(unsigned long addr) > } > > > -#define isa_inb(port) in_8(isa_itb(port)) Why move it below? Because its comment does not apply to the below? > #define isa_inw(port) (ISA_SEX ? in_be16(isa_itw(port)) : in_le16(isa_itw(port))) > #define isa_inl(port) (ISA_SEX ? in_be32(isa_itl(port)) : in_le32(isa_itl(port))) > #define isa_outb(val,port) out_8(isa_itb(port),(val)) > #define isa_outw(val,port) (ISA_SEX ? out_be16(isa_itw(port),(val)) : out_le16(isa_itw(port),(val))) > #define isa_outl(val,port) (ISA_SEX ? out_be32(isa_itl(port),(val)) : out_le32(isa_itl(port),(val))) > > +/* for APNE 100 Mbit cards - hope the APNE 100 case will be eliminated as > + * dead code if MULTI_ISA is not set */ I don't think this comment is needed. > +#define isa_inb(port) ((ISA_TYPE == ISA_TYPE_AG100) ? ((port) & 1 ? isa_inw((port) - 1) & 0xff : isa_inw(port) >> 8) : in_8(isa_itb(port)) > + > #define isa_readb(p) in_8(isa_mtb((unsigned long)(p))) > #define isa_readw(p) \ > (ISA_SEX ? in_be16(isa_mtw((unsigned long)(p))) \ Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds